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Detached Glycan Analysis in Byos® 
 
Protein Metrics – Customer Success Team, August 2019 

 
Introduction 
 
The analysis of glycosylated proteins used for biotherapeutics involves multiple techniques 
to complete the characterization. At the intact, subunit, and peptide levels the overall profile, 
site occupancy, and some degree of structural information is obtainable. However, detailed 
analysis of the glycans can add significant information and is used as a technique for data in 
regulatory filings, development, and quality control.   The detached glycan assay can provide 
critical information about linkages, antennary structure, and isomers to complement other 
experiments.  
 
In the example below, we show detached glycans from a glycan standard on a HILIC-FL-MS 
system with a column, an LC, and a mass spectrometer, all from different vendors. Mixed 
systems such as this are often the norm in modern laboratories. The practicalities of 
performing this analysis might therefore mean that the mass spectrometry data is acquired 
with one manufacturer’s software, and the fluorescence trace with another. In Byos 
Software, they can all be brought together in one platform allowing faster review and 
analysis. 
 

 
 
In this application, note we describe detached glycan analysis using Byos, a vendor-neutral, 
technique-neutral, automated processing and reporting software. With optional tools for 
GMP environments, the Byos platform can be used from research to QC. 
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Summary 
 

 Executing the Byos Glycan Workflow 
 Configuring the workflow 

o Optionally Adding a CSV Fluorescence Trace 
o Modifying the Glycan Table 
o Configuring Labels and Labeling Options 
o Configuring the MS Polarity 

 Reviewing the Project  
o Inspecting the Chromatogram and Auto Assigning Candidates 
o Filter Options 
o Refining Assignments  
o Customizing Chromatogram Labels 

 Producing reports 
 Appendix 

 

 
I. Executing the Byos N-Glycan Workflow 
 
 Click one of the Detached Glycan icons to launch a workflow  
 

 
 
 Drag & drop raw data files  
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 Select MS Trace 

 

 Create the project        
 
 
 
 
 

 
II. Configuring the Workflow 

Optionally Adding a CSV Optical Trace 
Even if the fluorescence or UV trace is not captured by the MS control software, it is still 
possible annotate this data in the Byos project.  To do so, export the fluorescence traces to X, 
Y (intensity, time) data in a CSV format.  Add this CSV file to the appropriate line on the 
Samples tab as shown below. 
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Modifying the Glycan Table 
The glycans included in the default workflows, while representative of many common 
therapeutic molecules, are not exhaustive. For example, the default file has only G1F (and by 
default will only automatically assign this annotation to one peak), but you may know the 
relative retention times your organization observes for G1Fa & G1Fb and would like to 
include this information to refine the resultant annotations.  This is easily done by importing 
a CSV file with user-specific annotation information. The default glycan files are located in 
the following directory (if default file paths are selected during installation of the software): 
C:\Program Files\ProteinMetrics\PMI-Suite\Base\presets\Byomap\glycan_tables. These 
files can be copied and edited with additional glycans, short name, and retention time 
boundaries.   

 Note: When adding from CSV, the system will append the contents of the file, so if you 
have redundant entries (i.e., a complete file) delete the existing entries before adding 
the CSV. 

Configuring Labels and Labeling Options 
Glycans are often analyzed after sample processing such as labelling with a fluorophore that 
enables accurate quantification. The Byos user interface provides a list of the most 
frequently used labels.  Adducts are also a frequent source of complexity; the user also has 
tools to select those which are likely in the sample.  These settings are found on the Glycan 
options tab and permit control of the related species that are labeled in the final 
chromatogram.  A default list of many common fluorophores is included with the ability 
select the appropriate reagent simply by clicking the associated radio button.  For 
organizations using novel reagents, a custom option is available.   

 Note: The mass added along with the selection of the custom option should be the net 
delta mass of the label, not the reagent mass.   

 

 
 

Other options available on this tab include a control to tell the software to look for unlabeled 
glycans along with the labeled counterparts.  This function is helpful when trying to identify 
unknown species in early analyses.  Similarly, the “Add Adduct” button at the bottom of the 
screen will facilitate the addition of both preconfigured and custom adducts. 



APPLICATION NOTE      
 
 

Technical Note – Detached Glycan Analysis – August 2019 5

Configuring the MS Polarity 
The detached glycan workflows expect negative mode data by default, though this is easily 
changed using settings available on the Processing Nodes tab.  To switch to positive mode, 
you simply change the default text in the “Advance Configuration” section to 
“NegativeMode = 0” rather than “NegativeMode = 1”. 
 

 
 

 
III. Reviewing the Project 
 
Upon completion of project execution, Byos will open a Byomap tab with the project and a 
report based on the project.  At first glance, the report will be blank and no assignments 
will have been made in the project.  This is not an error, it is actually by design so that you 
can review and adjust the peaks in your chromatogram before you assign identifications to 
the peaks.  
 

 
 



APPLICATION NOTE      
 
 

Technical Note – Detached Glycan Analysis – August 2019 6

If peaks are not automatically picked in the desired trace, select the trace you desire to 
annotate then click “Edit”→ “Recompute elution peaks and baseline” then click “OK” on the 
box that pops up and the software will pick peaks in the selected trace.  This feature can 
also be used to recompute peaks if you want to try different peak picking or time settings. 
 

  
 

Inspecting the Chromatogram and Auto-Assigning Candidates 
While the peak-picking algorithms are quite good, you may still want to adjust some peaks.  
For example, in the following chromatogram, peak 19 has a tailing bump that might be better 
annotated as an independent peak.  This is easy to do by selecting the peak and pressing the 
“Split Peaks” button; this will automatically split the peak in two.  You may also add, merge, 
and delete peaks in the same fashion.  It is also possible to manually adjust peak areas by 
moving the pink bars and set the MS1 that is displayed by moving the central blue bar. 
 

 
 
Once the chromatogram is satisfactory, return to the “Edit” menu and select “Auto assign 
candidates”.  Within a short time of starting the auto assignment, you should now see that 
most peaks are identified. 
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Filter Options 
Filters that control the peaks picked and automatic candidate assignments can be adjusted 
using the “Filter options” dialog box.  The box is accessed by clicking on the magnifying 
glass icon.  The resultant pop-up box contains three tabs; one for filtering elution peaks, 
one for filtering candidates, and another that controls candidate match options. 
 

 
 

Key options on the “Elution peak filters” tab include a setting to limit the retention times 
between which peaks will be picked.  A second control establishes the minimum peak area 
of a feature to be integrated and assigned.  The retention time limits are particularly useful 
for omitting contaminating species that are either too hydrophilic or too hydrophobic.  The 
“Minimum peak area %” can be used to set the sensitivity level at which peaks will be 
annotated.  
 
The “Candidate filters” tab is largely aimed at defining which candidates are available for 
matching to your MS1 spectrum.  Since glycan assignments are currently based solely on 
MS1, only a few of the options on this tab are relevant to detached glycan processing.   The 
“Expand peak search area by” option allows an automatic increase the time range within 
which a peak may be identified.  If options are checked in the “Filter Candidates table based 
on MS1 mass accuracy tolerance” section, those candidate types will be removed from 
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consideration if they do not meet the mass accuracy specified on the “Candidate match 
options to MS1 tab” (as described in the following section). 
 

 
 
The final tab, “Candidate match options to MS1”, is perhaps one of the most important, as 
the choices here define how candidates will be matched to MS1 spectra.  “Charge range” 
limits the acceptable range of z values used in making assignments. “Tolerance (ppm)” sets 
the maximum mass deviation allowed for assignment, while “Minimum peak intensity 
percent” establishes the minimum relative abundance of a peak that might be annotated in 
a given spectrum.  This option is used to assure that annotated species are sufficiently 
abundant before annotation.  Finally, ions below the “Minimum m/z” limit are ignored. 
 

 
 

Refining Assignments 
After auto assignments are made, occasionally some peaks may still be unassigned. This 
often occurs with isobaric species such as G1Fa and G1Fb. The software is currently designed 
to automatically assign each species to only one peak.  For that reason, the largest G1F peak 
will be annotated with G1F, but the smaller may be unlabeled, as in the following example.  
It is a simple matter to select the peak, see that the candidate is suggested, and select that 
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candidate ID for assignment to the peak by checking the “Valid” box.  Once validated, the new 
identification will be shown on the chromatogram.  It is also possible to add a candidate that 
was missing from the candidates list by pressing the “Add Candidate” button. 
 

 
 

Customizing Chromatogram Labels 
The default chromatogram labels will show the glycan, fluorescent tag, and adducts.  It is 
possible, however, to customize these labels by clicking the “Labels” button above the 
chromatogram.  This will bring up a dialog box with the current labeling scheme.  On the box, 
you will find a Short Codes button that will show the fields that can be added to the label 
(double-clicking a Short Code will add it to the label). 
 

 
 

It is also possible to include bits of javascript code to change the data values. For example, 
one popular script removes the fluorescent tags and adducts from chromatogram labels.   
This sample script is included in the appendix and could be cut and pasted into the label 
dialog as shown to obtain more concise labels.  For help customizing other labels, contact 
support@proteinmetrics.com. 
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IV. Producing Reports 
 
When the analysis is completed, Byos opens up not only the inspection view, but also the 
corresponding report as tab within the Byos window.  However, because assignments are 
not made immediately upon project open, the default report will initially be empty. To 
refresh the report after you have completed assignments in the project, return to the report 
tab and select “Tabs”→ “Update tab content”. 
 
 

 
 
If the report tab is ever closed, it can be reopened by clicking the report tab just below the 
menu bar or alternatively by selecting “File”→ “Export”→ “Generate configurable pivot 
summary…”.  
 

  
 
The default glycan report configuration includes project options, annotations by peak 
number and glycan, and bar charts showing both glycan and peak areas. Although the report 
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is associated with the project by default, if you ever make changes and want to revert to the 
original report, you can do so by selecting “File”→ ”Presets”→ ”Report Presets”→ 
“Bmap_Detached_Glycan.rptc”.  An example of the default report follows. 
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To include chromatogram and MS1 images in the report, click “Tabs”→ “Add Plots”.  This step 
can take a few minutes depending on the number of glycans included in the analysis.  
 

 
 
 
Hide configuration fields before exporting. 
 

 
 
Click “File” →”Export” → ”Export to PDF…” to generate a single .pdf file including all of the 
tabs.  
 
For more information on how to customize reports, please see our related videos available 
at https://www.proteinmetrics.com/resources/#videos-tutorials or contact the Customer 
Success Team at support@proteinmetrics.com. 
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Appendix 

Sample Label Script 
Copy and paste the following script in its entirety to switch to a more concise label format: 
 
[PeaksDynamicNumber] <script>  
   (function () { 
 
    var OutFormat = " "; 
    var InSeqStr = join("[Sequence]"); 
    var InSeq = InSeqStr.split(";"); 
    var OmitStr = [ 
    ["2-AA", 4], 
    ["2-AB", 4], 
    ["APTS", 4], 
    ["InstantAB", 9], 
    ["InstantPC", 9], 
    ["Procainamide", 12], 
    ["RapiFluor", 9], 
    ["Reduced", 7]]; 
 
    for (i=0; i < InSeq.length; i++){ 
        var TruncSeq =""; 
        var Omit =""; 
        var Len = 0; 
        for (j=0; j < OmitStr.length; j++){ 
            if (InSeq[i].indexOf(OmitStr[j][0])>=0){ 
                Omit = OmitStr[j][0]; 
                Len = OmitStr[j][1]; 
            } 
            } 
        if  (InSeq[i]) {TruncSeq = InSeq[i].substring(InSeq[i].indexOf(Omit) + Len); 
                } 
        if (OutFormat == " "){ 
               OutFormat = TruncSeq; 
        } else { 
               OutFormat = OutFormat +"; "+" "+TruncSeq; 
        } 
    } 
    return OutFormat; 
    })(); 
</script> 
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